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Chapter 1. MicroEJ Overview

1.1. MicroEJ Editions
MicroEJ offers a comprehensive toolset to build the embedded sofware of a device. The toolset covers
two levels in device software development:

• MicroEJ SDK for device firmware development

• MicroEJ Studio for application development

The firmware will generally be produced by the device OEM, it includes all device drivers and a specific
set of MicroEJ OS functionalities useful for application developers targeting this device.

Figure 1.1. MicroEJ OS Development Tools Overview

Using the MicroEJ SDK tool, a firmware developer will produce two versions of the MicroEJ OS binary,
each one able to run applications created with the MicroEJ Studio tool:

• A firmware binary to be flashed on OEM devices

• A Virtual Device which will be used as a device simulator by application developers

Using the MicroEJ Studio tool, an application developer will be able to:

• Import Virtual Devices matching his target hardware in order to develop and test applications
on the simulator.

• Deploy the application locally on an hardware device equipped with the MicroEJ OS firmware

• Package and publish the application on a store, enabling remote end users to install it on their
devices.
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1.2. Firmware

1.2.1. Bootable Binary with Core Services
A MicroEJ firmware is a binary software program that can be programmed into the flash memory of a
device. A MicroEJ firmware includes an instance of a MicroEJ OS linked to:

• underlying native libraries and BSP + RTOS,

• MicroEJ libraries and application code (C and Java code).

Figure 1.2. MicroEJ Firmware Architecture

1.2.2. Specification
The set of libraries included in the firmware and its dimensioning limitations (maximum number
of simultaneous threads, open connections, …) are firmware specific. Please refer to http://
developer.microej.com/getting-started.html firmware release notes.
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Chapter 2. MicroEJ SDK Getting Started

2.1. Introducing MicroEJ SDK
MicroEJ SDK provides tools based on Eclipse to develop software applications for MicroEJ-ready de-
vices. MicroEJ SDK allows application developers to write MicroEJ applications and run them on a vir-
tual (simulated) or real device.

This document is a step-by-step introduction to application development with MicroEJ SDK. The pur-
pose of MicroEJ SDK is to develop for targeted MCU/MPU computers (IoT, wearable, etc.) and it is there-
fore a cross-development tool.

Unlike standard low-level cross-development tools, MicroEJ SDK offers unique services like hardware
simulation and local deployment to the target hardware.

Application development is based on the following elements:

• MicroEJ SDK, the integrated development environment for writing applications. It is based on
Eclipse and is relies on the integrated Java compiler (JDT). It also provides a dependency man-
ager for managing MicroEJ Libraries (see Section 3.5, “Library Dependency Manager”). The cur-
rent version of MicroEJ SDK is built on top of Eclipse Mars (http://www.eclipse.org/
downloads/packages/release/Mars/2).

• MicroEJ Platform, a software package including the resources and tools required for building
and testing an application for a specific MicroEJ-ready device. MicroEJ platforms are imported
into MicroEJ SDK within a local folder called MicroEJ Platforms repository. Once a MicroEJ plat-
form is imported, an application can be launched and tested on simulator. It also provides a
means to locally deploy the application on a MicroEJ-ready device.

• MicroEJ-ready device, an hardware device that will be programmed with a MicroEJ firmware. A
MicroEJ firmware is a binary instance of MicroEJ OS for a target hardware board.

Starting from scratch, the steps to go through the whole process are detailed in the following sections
of this chapter :

• Download and install a MicroEJ Platform

• Build and run your first application on simulator

• Build and run your first application on target hardware

2.2. Setup MicroEJ SDK

2.2.1. Download and Install a MicroEJ Platform
MicroEJ SDK being a cross development tool, it does not build software targeted to your host desktop
platform. In order to run MicroEJ applications, a target hardware is required. Several commercial tar-
gets boards from main MCU/MPU chip manufacturers can be prepared to run MicroEJ applications, you
can also run your applications without one of these boards with the help of a MicroEJ Simulator.
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A MicroEJ Platform is a software package including the resources and tools required for building and
testing an application for a specific MicroEJ-ready device. MicroEJ Platforms are available at http://
developer.microej.com/getting-started.html.

After downloading the MicroEJ Platfom, launch MicroEJ SDK on your desktop to start the process of
Platform installation :

• Open the Platform view in MicroEJ SDK, select Window > Preferences > MicroEJ >
Platforms. The view should be empty on a fresh install of the tool

Figure 2.1. MicroEJ Platform Import

• Press Import... button.

• Choose Select File... and use the Browse option to navigate to the .jpf file containing
your MicroEJ Platform, then read and accept the license agreement to proceed.
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Figure 2.2. MicroEJ Platform Selection

• The MicroEJ Platform should now appear in the Platforms view, with a green valid mark.

Figure 2.3. MicroEJ Platform List
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2.2.2. Setup Ivy Repository

MicroEJ SDK uses an Ivy repository which provides a set of libraries. MicroEJ SDK is already configured
to use an online Ivy repository. For offline use, you can download the offline repository available on
website http://developer.microej.com/4.0/ivy/, and follow the described steps to use
this repository.

2.3. Build and Run an Application

2.3.1. Create a MicroEJ Standalone Application

• Create a project in your workspace. Select File > New > MicroEJ Standalone Ap-
plication Project.

Figure 2.4. New MicroEJ Standalone Application Project

• In the New MicroEJ Project window, fill Project name and uncheck the MicroEJ library
EDC-1.2 in the Runtime Environment list. Click on Finish. You now have an application
project created in MicroEJ SDK.
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Figure 2.5. MicroEJ Standalone Application Project Configuration

• Next step consists in specifying the classpath of your application using Ivy dependencies. Right
click on the project and select New > File. Fill the File name: module.ivy. Click on
Finish.
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Figure 2.6. New Ivy File

• The Eclipse internal text editor allows you to edit the new created file. Copy / paste the following
lines and save the file:

        <ivy-module version="2.0"> 

         <info module=""/>

         <dependencies>

          <dependency org="ej.api" name="edc" rev="1.2.+"/>

          <dependency org="ej.api" name="bon" rev="1.2.+"/>

         </dependencies>

        </ivy-module>

       

• Right click on the project and select Build Path > Add Libraries. Select IvyDE Man-
aged Dependencies and click on Next. Fill the Ivy File name: module.ivy. Finally,
click on Finish and on OK.
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Figure 2.7. MicroEJ Application Build Path

The project now uses some Ivy dependencies. You can see them opening the Ivy tree:

Figure 2.8. MicroEJ Application Dependencies

• Right click on the source folder src and select New > Package. Give a name:
com.mycompany. Click on Finish.
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Figure 2.9. New Package

• The package com.mycompany is available under src folder. Right click on this package and
select New > Class. Give a name: Test and check the box public static void

main(String[] args). Click on Finish.
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Figure 2.10. New Class

• The new class has been created with an empty main() method. Fill the method body with the
following lines:

System.out.println("hello world!");

.
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Figure 2.11. MicroEJ Application Content

The test application is now ready to be executed. See next chapters.

2.3.2. Run on the Simulator

To run the sample project on Simulator, select it in the left panel then right-click and select Run >
Run as > MicroEJ Application.

Figure 2.12. MicroEJ OS Development Tools Overview

MicroEJ SDK console will display Launch steps messages.
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     =============== [ Initialization Stage ] ===============

     =============== [ Launching on Simulator ] ===============

     hello world!

     =============== [ Completed Successfully ] ===============

     

     SUCCESS

    

2.3.3. Run on the Hardware Device
Compile an application, connect the hardware device and deploy on it is hardware dependant. These
steps are described in dedicated documentation available inside the MicroEJ Platform. This documen-
tation is accessible from the MicroEJ Resources Center view.

Note

MicroEJ Resources Center view may have been closed. Click on Help > MicroEJ Re-
sources Center to reopen it.

Open the menu Manual and select the documentation [hardware device] MicroEJ Plat-
form, where [hardware device] is the name of the hardware device. This documentation features
a guide to run a built-in application on MicroEJ Simulator and on hardware device.

Figure 2.13. MicroEJ Platform Guide

2.4. Application Development
The following sections of this document shall prove useful as a reference when developing applications
for MicroEJ. They cover concepts essential to MicroEJ applications design.

In addition to these sections, by going to http://developer.microej.com/, you can access a
number of helpful resources such as:

• Libraries,
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• Application Examples, with their source code,

• Documentation (HOWTOs, Reference Manuals, APIs javadoc...)
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Chapter 3. MicroEJ Classpath
MicroEJ applications run on a target device and their footprint is optimized to fulfill embedded con-
straints. The final execution context is an embedded device that may not even have a file system. Files
required by the application at runtime are not directly copied to the target device, they are compiled
to produce the application binary code which will be executed by MicroEJ OS core engine.

As a part of the compile-time trimming process, all types not required by the embedded application
are eliminated from the final binary.

MicroEJ Classpath is a developer defined list of all places containing files to be embedded in the final
application binary. MicroEJ Classpath is made up of an ordered list of paths. A path is either a folder or
a zip file, called a JAR file (JAR stands for Java ARchive).

• Section 3.1, “Application Classpath” explains how the MicroEJ classpath is built from a MicroEJ
application project.

• Section 3.2, “Classpath Load Model” explains how the application content is loaded from Mi-
croEJ Classpath.

• Section 3.3, “Classpath Elements” specifies the different elements that can be declared in Mi-
croEJ Classpath to describe the application content.

• Section 3.4, “Foundation vs Add-On Libraries” explains the different kind of libraries that can be
added to MicroEJ Classpath.

• Finally, Section 3.5, “Library Dependency Manager” shows how to manage libraries dependen-
cies in MicroEJ.

3.1. Application Classpath
The following schema shows the classpath mapping from a MicroEJ application project to the MicroEJ
Classpath ordered list of folders and JAR files. The classpath resolution order (left to right) follows the
project appearance order (top to bottom).
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Figure 3.1. MicroEJ Application Classpath Mapping

3.2. Classpath Load Model
A MicroEJ Application classpath is created via the loading of :

• an entry point type

• all *.[extension].list files declared in a MicroEJ Classpath.

The different elements that constitute an application are described in Section  3.3, “Classpath Ele-
ments”. They are searched within MicroEJ Classpath from left to right (the first file found is loaded).
Types referenced by previously loaded MicroEJ Classpath elements are loaded transitively.
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Figure 3.2. Classpath Load Principle

3.3. Classpath Elements
The MicroEJ Classpath contains the following elements:

• An entrypoint described in section Section 3.3.1, “Application Entry Points”

• Types in .class files, described in section Section 3.3.2, “Types”

• Raw resources, described in section Section 3.3.3, “Raw Resources”

• Immutables Object data files, described in Section Section 3.3.4, “Immutable Objects”

• Images and Fonts resources

• *.[extension].list files, declaring contents to load. Supported list file extensions and
format is specific to declared application content and is described in the appropriate section.

3.3.1. Application Entry Points
MicroEJ application entry point is a class that contains a public static void main(String[])
method. In case of MicroEJ Sandboxed Application, this entry point is automatically generated by Mi-
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croEJ Studio from declared Activity and/or BackgroundService types. In case of a MicroEJ Standalone
application, this has to be defined by the user.

3.3.2. Types

MicroEJ types (classes, interfaces) are compiled from source code (.java) to classfiles (.class).
When a type is loaded, all types dependencies found in the classfile are loaded (transitively).

A type can be declared as a Required type in order to enable the following usages:

• to be dynamically loaded from its name (with a call to Class.forName(String))

• to retrieve its fully qualified name (with a call to Class.getName())

A type that is not declared as a Required type may not have its fully qualified name (FQN) embedded.
Its FQN can be retrieved using the stack trace reader tool (see Section 4.2, “Strack Trace Reader”).

Required Types are declared in MicroEJ Classpath using *.types.list files. The file format is a stan-
dard Java properties file, each line listing the fully qualified name of a type. Example:

Example 3.1. Required Types *.types.list File Example

# The following types are marked as MicroEJ Required Types

com.mycompany.MyImplementation

java.util.Vector

3.3.3. Raw Resources

Raw resources are binary files that need to be embedded by the application so that they may be dynam-
ically retrieved with a call to Class.getResourceAsStream(java.io.InputStream). Raw
Resources are declared in MicroEJ Classpath using *.resources.list files. The file format is a stan-
dard Java properties file, each line is a relative / separated name of a file in MicroEJ Classpath to be
embedded as a resource. Example:

Example 3.2. Raw Resources *.resources.list File Example

# The following resource is embedded as a raw resource

com/mycompany/MyResource.txt

3.3.4. Immutable Objects

Immutables objects are regular read-only objects that can be retrieved with a call to
ej.bon.Immutables.get(String). Immutables objects are declared in files called immutable
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objects data files, which format is described in the [B-ON] specification (http://e-s-r.net). Im-
mutables objects data files are declared in MicroEJ Classpath using *.immutables.list files. The
file format is a standard Java properties file, each line is a / separated name of a relative file in MicroEJ
Classpath to be loaded as an Immutable objects data file. Example:

Example 3.3. Immutable Objects Data Files *.immutables.list File Example

# The following file is loaded as an Immutable objects data files

com/mycompany/MyImmutables.data

3.3.5. System Properties

System Properties are key/value string pairs that can be accessed with a call to
System.getProperty(String). System properties are declared in MicroEJ Classpath
*.properties.list files. The file format is a standard Java properties file. Example:

Example 3.4. System Properties *.properties.list File Example

# The following property is embedded as a System property

com.mycompany.key=com.mycompany.value

3.3.6. Images

3.3.6.1. Overview

Images are graphical resources that can be accessed with a call to
ej.microui.display.Image.createImage(). To be displayed, these images have to be con-
verted from their source format to the display raw format. The conversion can either be done at :

• build-time (using the image generator tool)

• run-time (using the relevant decoder library)

Images that must be processed by the image generator tool are declared in MicroEJ Classpath
*.images.list files. The file format is a standard Java properties file, each line representing a /
separated resource path relative to the MicroEJ classpath root referring to a standard image file (e.g.
.png, .jpg). The resource may be followed by an optional parameter (separated by a :) which defines
and/or describe the image output file format (raw format). When no option is specified, the image is
embedded as-is and will be decoded at run-time (although listing files without format specifier has no
impact on the image generator processing, it is advised to specify them in the *.images.list files
anyway, as it makes the run-time processing behavior explicit). Example:
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Figure 3.3. Image Generator *.images.list File Example

# The following image is embedded 
# as a PNG resource (decoded at run-time)
com/mycompany/MyImage1.png

# The following image is embedded 
# as a 16 bits format without transparency (decoded at build-time)
com/mycompany/MyImage2.png:RGB565

# The following image is embedded 
# as a 16 bits format with transparency (decoded at build-time)
com/mycompany/MyImage3.png:ARGB1555

3.3.6.2. Output Formats

3.3.6.2.1. No Compression

When no output format is set in the images list file, the image is embedded without any conversion /
compression. This allows you to embed the resource as well, in order to keep the source image char-
acteristics (compression, bpp etc.). This option produces the same result as specifiying an image as a
resource in the MicroEJ launcher.

Advantages:

• Preserves the image characteristics.

Disadvantages:

• Requires an image runtime decoder.

• Requires some RAM in which to store the decoded image

Figure 3.4. Unchanged Image Example

image1

3.3.6.2.2. Display Output Format

This format encodes the image into the exact display memory representation. If the image to en-
code contains some transparent pixels, the output file will embed the transparency according to the
display's implementation capacity. When all pixels are fully opaque, no extra information will be stored
in the output file in order to free up some memory space.

Advantages:

• Drawing an image is very fast.

• Supports alpha encoding.
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Disadvantages:

• No compression: the image size in bytes is proportional to the number of pixels.

Figure 3.5. Display Output Format Example

image1:display

3.3.6.2.3. Generic Output Formats

Depending on the target hardware, several generic output formats are available. Some formats may
be directly managed by the BSP display driver. Refer to the platform specification to retrieve the list
of natively supported formats.

Advantages:

• The pixels layout and bits format are standard, so it is easy to manipulate these images on the
C-side.

• Drawing an image is very fast when the display driver recognizes the format (with or without
transparency).

• Supports or not the alpha encoding: select the most suitable format for the image to encode.

Disadvantages:

• No compression: the image size in bytes is proportional to the number of pixels, the transparen-
cy, and the bits-per-pixel.

Select one the following format to use a generic format:

• ARGB8888: 32 bits format, 8 bits for transparency, 8 per color.

• RGB888: 24 bits format, 8 per color. Image is always fully opaque.

• ARGB4444: 16 bits format, 4 bits for transparency, 4 per color.

• ARGB1555: 16 bits format, 1 bit for transparency, 5 per color.

• RGB565: 16 bits format, 5 or 6 per color. Image is always fully opaque.

• A8: 8 bits format, only transparency is encoded. The color to apply when drawing the image, is
the current GraphicsContext color.

• A4: 4 bits format, only transparency is encoded. The color to apply when drawing the image, is
the current GraphicsContext color.

• A2: 2 bits format, only transparency is encoded. The color to apply when drawing the image, is
the current GraphicsContext color.

• A1: 1 bit format, only transparency is encoded. The color to apply when drawing the image, is
the current GraphicsContext color.

Figure 3.6. Generic Output Format Examples

image1:ARGB8888
image2:RGB565
image3:A4
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3.3.6.2.4. RLE1 Output Format

The image engine can display embedded images that are encoded into a compressed format which
encodes several consecutive pixels into one or more 16-bits words. This encoding manages a maximum
alpha level of 2 (alpha level is always assumed to be 2, even if the image is not transparent).

• Several consecutive pixels have the same color (2 words).

• First 16-bit word specifies how many consecutive pixels have the same color.

• Second 16-bit word is the pixels' color.

• Several consecutive pixels have their own color  (1 + n words).

• First 16-bit word specifies how many consecutive pixels have their own color.

• Next 16-bit word is the next pixel color.

• Several consecutive pixels are transparent (1 word).

• 16-bit word specifies how many consecutive pixels are transparent.

Advantages:

• Supports 0 & 2 alpha encoding.

• Good compression when several consecutive pixels respect one of the three previous rules.

Disadvantages:

• Drawing an image is slightly slower than when using Display format.

Figure 3.7. RLE1 Output Format Example

image1:RLE1

3.3.7. Fonts

3.3.7.1. Overview

Fonts are graphical resources that can be accessed with a call to
ej.microui.display.Font.getFont(). To be displayed, these fonts have to be converted at
build-time from their source format to the display raw format by the font generator tool. Fonts that
must be processed by the font generator tool are declared in MicroEJ Classpath *.fonts.list files.
The file format is a standard Java properties file, each line representing a / separated resource path
relative to the MicroEJ classpath root referring to a MicroEJ font file (usually with a .ejf file extension).
The resource may be followed by optional parameters which define :

• some ranges of characters to embed in the final raw file

• the required pixel depth for transparency.
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By default, all characters available in the input font file are embedded, and the pixel depth is 1 (i.e 1
bit-per-pixel). Example:

Figure 3.8. Font Generator *.fonts.list File Example

# The following font is embedded with all characters
# without transparency
com/mycompany/MyFont1.ejf

# The following font is embedded with only the latin 
# unicode range without transparency 
com/mycompany/MyFont2.ejf:latin

# The following font is embedded with all characters
# with 2 levels of transparency
com/mycompany/MyFont2.ejf::2

MicroEJ font files conventionally end with the .ejf suffix and are created using the Font Designer (see
Section 4.1, “Font Designer”).

3.3.7.2. Font Range

The first parameter is for specifying the font ranges to embed. Selecting only a specific set of characters
to embed reduces the memory footprint. Several ranges can be specified, separated by ;. There are
two ways to specify a character range: the custom range and the known range.

3.3.7.2.1. Custom Range

Allows the selection of raw Unicode character ranges.

Examples:

• myfont:0x21-0x49: Embed all characters from 0x21 to 0x49 (included).

• myfont:0x21-0x49,0x55: Embed all characters from 0x21 to 0x49 and character 0x55

• myfont:0x21-0x49;0x55: Same as previous, but done by declaring two ranges.

3.3.7.2.2. Known Range

A known range is a range defined by the "Unicode Character Database" available on http://
www.unicode.org/. Each range is composed of sub ranges that have a unique id.

Examples:

• myfont:latin: Embed all latin characters.

• myfont:latin(5): Embed all latin characters of sub range 5 (0xD8 to 0xF6).

• myfont:latin(1-5): Embed all latin characters of sub ranges 1 to 5.

• myfont:latin(1-5,7): Embed all latin characters of sub ranges 1 to 5 and 7.

• myfont:latin(1-5);latin(7): Same as previous, but done by declaring two ranges.
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• myfont:latin(1-5);han:  Embed all latin characters of sub ranges 1 to 5, and all han char-
acters.

3.3.7.3. Transparency

The second parameter is for specifying the font transparency level (1, 2, 4 or 8).

Examples:

• myfont:latin:4: Embed all latin characters with 4 levels of transparency

• myfont::2: Embed all characters with 2 levels of transparency

3.4. Foundation vs Add-On Libraries
A MicroEJ Foundation Library is a MicroEJ Core library that provides core runtime APIs or hardware-de-
pendent functionality. A Foundation library is divided into an API and an implementation. A Foundation
library API is composed of a name and a 2 digits version (e.g. EDC-1.2, MWT-2.0) and follows the se-
mantic versioning (http://semver.org) specification. A Foundation library API only contains pro-
totypes without code. Foundation library implementations are provided by MicroEJ Platforms. From a
MicroEJ Classpath, Foundation library APIs dependencies are automatically mapped to the associated
implementations provided by the platform on which the application is being executed.

A MicroEJ Add-On Library is a MicroEJ library that is implemented on top of MicroEJ Foundation Li-
braries (100% full Java code). A MicroEJ Add-on Library is distributed in a single JAR file, with most
likely a 3 digits version and provides its associated source code.

Foundation and add-on libraries are added to MicroEJ Classpath by the application developer using
Ivy (see Section 3.5, “Library Dependency Manager”).

Figure 3.9. MicroEJ OS Foundation and Add-On Libraries

3.5. Library Dependency Manager
MicroEJ uses Ivy (http://ant.apache.org/ivy) as its dependency manager for building MicroEJ
classpath.

An Ivy configuration file must be provided in each MicroEJ project to solve classpath dependencies.
Multiple Ivy configuration file templates are available depending on the kind of MicroEJ application
created.
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Example 3.5. Ivy File Template for a Sandboxed Application

  <ivy-module version="2.0"> 

   <info module=""/>

   <dependencies>

    <!-- Declare a Foundation Library API dependency -->

    <dependency org="ej.api" name="edc" rev="1.2.+"/>

    <dependency org="ej.api" name="bon" rev="1.2.+"/>

    

    <!-- Declare an Add-On Library dependency -->

    <dependency org="org.kxml2" name="kxml2" rev="2.3.1"/>

   </dependencies>

  </ivy-module>

  

Dependencies are declared within the <dependencies> tag

• Foundation libraries are declared using the "ej.api" organization. Without this, they will be
considered as a regular Add-On libraries and will not be mapped to the associated implemen-
tation provided by the platform.

• Add-On libraries are declared with the default runtime configuration. All their declared depen-
dencies will be fetched transitively.

3.6. Central Repository
The MicroEJ Central Repository is the Ivy repository maintained by MicroEJ. It contains Foundation li-
brary APIs and numerous Add-On Libraries. Foundation libraries APIs are distributed under the organi-
zation ej.api. All other artifacts are Add-On libraries.

For more information, please visit https://developer.microej.com.
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Chapter 4. Additional Tools

4.1. Font Designer
MicroEJ Font Designer allows to create embedded fonts files (see Section 3.3.7, “Fonts”) from standard
font files formats. The Font Designer documentation is available at: Help > Help Contents >
Font Designer User Guide.

4.2. Strack Trace Reader
When an application is deployed on a device, stack traces dumped on standard output are not directly
readable: non required types (see Section 3.3.2, “Types”) names, methods names and methods line
numbers may not have been embedded to save code space. A stack trace dumped on the standard
output can be decoded using the Stack Trace Reader tool.

Starting from the MicroEJ application example (see Section 2.3, “Build and Run an Application”), write
a new line to dump the currently executed stack trace on the standard output.

Figure 4.1. Code to Dump a Stack Trace

On successful deployment, the application is started on the device and the following trace is dumped
on standard output.

Figure 4.2. Stack Trace Output



Additional Tools

27

To create a new MicroEJ Tool configuration, right-click on the application project and click on Run
As... > Run Configurations....

In Execution tab, select the Stack Trace Reader tool.

Figure 4.3. Select Stack Trace Reader Tool

In Configuration tab, browse the previously generated application binary file with debug informa-
tion (application.out)

Figure 4.4. Stack Trace Reader Tool Configuration

Click on Run button and copy/paste the trace into the Eclipse console. The decoded trace is dumped
and the line corresponding to the application hook is now readable.
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Figure 4.5. Read the Stack Trace

The stack trace reader can simultaneously decode heterogeneous stack traces with lines owned by dif-
ferent applications and the firmware. Other debug information files can be appended using the Ad-
ditional object files option. Lines owned by the firmware can be decoded with the firwmare
debug information file (optionally made available by your firmware provider).
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